cisco路由上封BT方法比较及分析




最近为了封BT,几乎把NBO的网络论坛找遍了,用NBAR (Network-Based Application Recognition)网络应用识别

  NBAR是一种动态能在四到七层寻找协议的技术,它不但能做到普通ACL能做到那样控制静态的TCP UDP的报,也能做到控制一般ACLs不能做到动态的端口的那些协议(如BT)之类.

  我就说说过程:

  1到http://www.cisco.com/pcgi-bin/tablebuild.pl/pdlm 下载bittorrent.pdlm,(要CCO的)

  2放到TFTP,然后用copy tftp disk2(大多数应该是flash)

  拷到路由器中,

  route7206#conf t

  Enter configuration commands, one per line. End with CNTL/Z.

  route7206(config)#ip nbar pdlm bittorrent.pdlm

  route7206(config)#

  !

  ip nbar pdlm bittorrent.pdlm

  !

  1.) 创建一个 a class-map and policy map 并且把它应用到相应的端口:

  得到关于BT的部分是

  class-map match-all bittorrent

  match protocol bittorrent

  !

  !

  policy-map bittorrent-policy

  class bittorrent

  drop

  !

  interface GigabitEthernet0/2

  description CONNECT INSIDE

  ip address 192.168.168.1 255.255.255.252 secondary

  ip address 192.168.21.1 255.255.255.0

  ip nat inside

  service-policy input bittorrent-policy

  service-policy output bittorrent-policy

  duplex full

  speed 1000

  media-type rj45

  no negotiation auto

  我实验了一下,这样的话,BT就不能下载,呵呵

  感觉目前这样的技术比较好,我正在实验去掉EMULE的方法.

  QQ:7581276 MAIL:lh@hutc.zj.cn [请转贴时保留我的EMAIL]

发表评论?

0 条评论。

发表评论


注意 - 你可以用以下 HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Time limit is exhausted. Please reload CAPTCHA.