在Linux下面安装VPN SERVER [原创]




在Linux下面安装VPN SERVER

在Linux下面安装VPN SERVER的话,需要用到pptpd这个包。http://www.poptop.org
Poptop is the PPTP server solution for Linux. Ports also exist for Solaris 2.6, OpenBSD, FreeBSD and others.

1.  如果Linux的内核版本低于2.6.15-rc1的话,你必须在kernel中加入MPPE的支持。一些内核里面已经包含了MPPE的支持。你可以使用  modprobe ppp-compress-18 && echo ok 来测试是否已经安装。
如果kernel中没有MPPE的支持,则必须安装MPPE的支持:下载最新的DKMS RPM和kernel_ppp_mppe RPM。下载地址:new MPPE module builder, http://sourceforge.net/project/showfiles.php?group_id=44827&package_id=120221

2. 升级PPP到2.4.3以上:
http://sourceforge.net/project/showfiles.php?group_id=44827&package_id=118989

3. 安装最新的pptpd rpm:
http://sourceforge.net/project/showfiles.php?group_id=44827&package_id=51373

4. 配置文件:
/etc/module.conf 2001年以前发布的Redhat Linux有这个文件
/etc/pptpd.conf – 主要配置文件,配置VPN地址等。
/etc/ppp/options.pptpd
/etc/ppp/chap-secrects – 用户名/密码

5. 启动Service: service pptpd start

6. 连接

打开IP路由:/etc/sysctl.conf
Net.ipv4.ip_forward = 1

大功告成

dkms-2.0.6-1.noarch.rpm
dkms-2.0.6-1.src.rpm
gcc-3.4.4-2.i386.rpm
glibc-devel-2.3.4-2.13.i386.rpm
glibc-headers-2.3.4-2.13.i386.rpm
glibc-kernheaders-2.4-9.1.98.EL.i386.rpm
kernel-devel-2.6.9-22.EL.i686.rpm
kernel_ppp_mppe-1.0.2-3dkms.noarch.rpm
kernel_ppp_mppe-1.0.2-3dkms.src.rpm
ppp-2.4.3-5.rhel4.i386.rpm
pptp-1.7.0-1.i386.rpm
pptpd-1.2.3-1.i386.rpm
pptpd-1.3.0-0.i386.rpm

G0dspeed原著

发表评论?

0 条评论。

发表评论


注意 - 你可以用以下 HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Time limit is exhausted. Please reload CAPTCHA.